The GUN Forum

Find answers, ask questions, and connect with our
community around the world.

home Forums – The GUN Forum Firearms Rifles AR15 Safety wont ”lock in place”

  • Safety wont ”lock in place”

     Neville updated 1 year ago 2 Members · 6 Posts
  • Neville

    Member
    May 19, 2021 at 1:21 am

    I built an ar platform a while back and the safety does not lock into safe and fire position. my safety works when in safe position. any ideas?

  • Buster-Hymin

    Guest
    May 19, 2021 at 1:21 am

    Sounds like your safety detent is missing.

  • mumblywumbles

    Guest
    May 19, 2021 at 1:21 am

    You have one of those safeties that’s progressive. So you can turn it to ‘30% safe’, ‘40% safe’ etc

  • Mysterious-Poop247

    Guest
    May 19, 2021 at 1:21 am

    Or rather when I push the spring onto it to put grip on it does not push that detent pin down now that I think about it. Is the pin too big? Hole too small or could ot be something else causing it to not move?

  • Phantom_517

    Guest
    May 19, 2021 at 1:21 am

    Is it unloaded? If so the safety won’t engage if its not charged

  • Mysterious-Poop247

    Guest
    May 19, 2021 at 1:21 am

    Thx guys come to find out when I was infantry in the army they thought us low level maintenance lol. This building ar stuff is an armorers job. I put put safe in backwards and the detent holes were on the opposite side of the detent pin and spring lol. Swapped it around and she works way better now. Thx guys.

Viewing 1 - 6 of 6 replies
Reply to: Neville
Your information:

Cancel
Start of Discussion
0 of 0 posts June 2018
Now